- #####################################################################################################
- ## ISIS
- #####################################################################################################
- # Be sure to set family iso on the interface to be placed into ISIS
- set interfaces <interface> family iso
- # By default Junos places interfaces as L1/L2
- # Default route leaking:
- L1 to L2 - all internal routes
- L2 to L1 - 0/0 route
- # L1/L2 will send the attached-bit down to L1 and it will act as a NSSA-like area. When the L1 interface
- # receives the attached-bit it will inject a 0/0 route into the RIB point to the L1/L2 interface.
- # To disable the attached bit use:
- set protocols isis ignore-attached-bit
- # Be careful with the "interface all" command, as it may have some unexpected consequences such as trying
- # to establish a neighbor on your fxp0 management interface. Use explicit interface names. If you must
- # use the "interface all" command, remember that if you also define another explicit interface such as
- # "interface ge-0/0/0.0 <options>" that it _doesn't_ inherit the "interface all" options.
- # ALWAYS include the interface lo0.0
- # L2 backbone must be contiguous.
- # Human-readable hostnames via TLV 137. Good to quickly verify that the router has the proper adjcancies .
- show isis hostname
- # Set LSP authentication (per area knob)
- set protocols isis level <level> authentication-type (simple|md5)
- set protocols isis level <level> authentication-key <key>
- # Set hello authentication (per interface knob)
- set protocols isis interface <interface> hello-authentication-type (simple|md5)
- set protocols isis interface <interface> hello-authentication-key <key>
- # Set lsp-interval
- set interfaces ge-0/0/0.0 lsp-interval <milliseconds>
- # L2 to L1 route summarization
- ## set aggregate route in routing-options
- set routing-options aggregate route 10/8
- ## set policy-options - what prefix to match
- set policy-options policy-statement isis-export term 1 from protocol aggregate route-filter 10/8 exact
- ## set policy-options - what level to go _to_
- set policy-options policy-statement isis-export term 1 to level 1
- ## set action
- set policy-options policy-statement isis-export term 1 then accept
- # L1 to L2 route summarization
- ## set aggregate route in routing-options
- set routing-optiong aggregate route 10/8
- ## set policy-options
- ### match exact route
- set policy-options policy-statement isis-export term 1 from protocol aggregate router-filter 10/8 exact
- ## set policy-options - what level to go _to_
- set policy-options policy-statement isis-export term 1 to level 2
- ## set action
- set policy-options policy-statement isis-export term 1 then accept
- ### suppress more specific routes (to prevent advertisements of both aggregate and more specific routes)
- set policy-options policy-statement isis-export term 2 from protocol isis
- set policy-options policy-statement isis-export term 2 from level 1
- set policy-options policy-statement isis-export term 2 to level 2
- ## set action
- set policy-options policy-statement isis-export term 2 then reject
- # Verify that a route is internal or external
- show route protocol isis <prefix> exact
- show isis database <sysid> detail
- # When using wide-metrics-only it makes the route internal. When there is a situtation where the L1 routers
- # are wide-metrics-only and are exporting external routes into the L1 area, they will appear as internal
- # routes. Also if there are any L1/L2 routers in the area that exported prefix will be automatically
- # redistributed from L1 into L2 because it's showing as an internal route. If narrow-metrics were used, the
- # L1/L2 routers would have to have an export policy to redistributed the prefix from L1 to L2.
- # Set DIS priority
- set protocols isis interface <interface> level <level> priority <level>
- ## Remember that the highest MAC address is the tie-breaker if the priorities are equal
- ## view current DIS
- show isis interface
source http://evilrouters.net/2011/01/18/cisco-iou-faq/ What is IOU? From the Cisco Engineering Education web site (a long time ago): IOS on Unix (IOU) is a fully working version of IOS that runs as a user mode UNIX (Solaris) process. IOU is built as a native Solaris image and run just like any other program. IOU supports all platform independent protocols and features. What operating systems does IOU run on? It is my understanding that, initially, IOU was Solaris (SPARC) only. Nowadays, however, there are also builds for OS X and Linux. Similar to dynamips, IOU allows you to build out a network topology on a computer, without the need for physical routers. This is useful for validating designs, proof-of-concept testing, and certification self-study. Is my system compatible with IOU? You will need to be running the operating system that your IOU image were built for, obviously. Other than that, there are no special requirements to run IOU. It is not very CPU- or memory-intensive, unlik...