I got this strange behaviour where the IPv6 doesn't work correctly or not working at all on LT interfaces.
http://www.juniper.net/techpubs/en_US/junos12.2/topics/concept/logical-systems-restrictions.html
Logical systems have the following operations and restrictions:
* You can configure only Frame Relay interface encapsulation on a logical tunnel interface (lt-) when it is configured with an IPv6 address.
So if you are using Logical Systems on Juniper and you have to do IPv6 labs avoid encapsulation ethernet.
Example
root@jnlab# show
interfaces {
lt-2/2/0 {
unit 46 {
encapsulation frame-relay;
dlci 100;
peer-unit 45;
family inet {
address 172.27.0.58/30;
}
family inet6 {
address 2008:4489:0:0::1/64;
}
}
}
}
root@jnlab# run ping 2008:4489::2 logical-system c1
PING6(56=40+8+8 bytes) 2008:4489::1 --> 2008:4489::2
16 bytes from 2008:4489::2, icmp_seq=0 hlim=64 time=0.427 ms
16 bytes from 2008:4489::2, icmp_seq=1 hlim=64 time=0.281 ms
^C
--- 2008:4489::2 ping6 statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 0.281/0.354/0.427/0.073 ms
http://www.juniper.net/techpubs/en_US/junos12.2/topics/concept/logical-systems-restrictions.html
Logical systems have the following operations and restrictions:
* You can configure only Frame Relay interface encapsulation on a logical tunnel interface (lt-) when it is configured with an IPv6 address.
So if you are using Logical Systems on Juniper and you have to do IPv6 labs avoid encapsulation ethernet.
Example
root@jnlab# show
interfaces {
lt-2/2/0 {
unit 46 {
encapsulation frame-relay;
dlci 100;
peer-unit 45;
family inet {
address 172.27.0.58/30;
}
family inet6 {
address 2008:4489:0:0::1/64;
}
}
}
}
root@jnlab# run ping 2008:4489::2 logical-system c1
PING6(56=40+8+8 bytes) 2008:4489::1 --> 2008:4489::2
16 bytes from 2008:4489::2, icmp_seq=0 hlim=64 time=0.427 ms
16 bytes from 2008:4489::2, icmp_seq=1 hlim=64 time=0.281 ms
^C
--- 2008:4489::2 ping6 statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 0.281/0.354/0.427/0.073 ms